Probleemoplossingsgids vir Apache HTTP

Apache HTTP is altyd lekker om te installeer. ‘N Paar dae terug installeer ek Apache 2.4 op CentOS VM en kom teë veelvuldige foute.


Ek het gedink dat dit nuttig sou wees om ‘n verwysing saam te stel.

APR nie gevind nie

[[Email protected] httpd-2.4.25] # ./configure –able-ssl
kyk vir die gekose uitleg … Apache
kyk vir werkende mkdir -p … ja
kyk na grep wat lang lyne hanteer en -e … / usr / bin / grep
kyk vir egrep … / usr / bin / grep -E
kontroleer die boustelsel tipe … x86_64-onbekend-linux-gnu
kontroleer die gasheerstelsel tipe … x86_64-onbekend-linux-gnu
kontroleer die teikenstelsel tipe … x86_64-onbekende-linux-gnu
instel:
configure: Configureer Apache Portable Runtime-biblioteek…
instel:
kyk vir APR … nee
configure: error: APR nie gevind nie. Lees asseblief die dokumentasie.
[[Email protected] httpd-2.4.25] #

APR staan ​​vir “Apache Portable Runtime” en moet vanaf die bron saamgestel word. As u in dieselfde situasie is as ek, sal die volgende testament redding jy.

eerste, u moet APR installeer.

  • Laai die nuutste weergawe van APR af met behulp van wget

wget https://www-eu.apache.org/dist/apr/apr-1.6.3.tar.gz .

  • Onttrek die afgelaaide lêer

gunzip -c apr-1.6.3.tar.gz | teer xvf –

  • dit sal ‘n nuwe lêergids skep “April-1.6.3
  • Gaan na binne en stel dit saam met die instelopdrag

./ instel

Dit sal ‘n paar sekondes duur en sodra u klaar is, sal u vinnig terugkom (sorg dat daar geen fout is nie).

  • Die laaste stap sou wees om te installeer met behulp van make-opdrag

make
maak installeer

Nadat ek dit gedoen het, het ek probeer om Apache te installeer en het ek weer ‘n fout gekry.

April-gebruik nie gevind nie

[[Email protected] httpd-2.4.25] # ./configure –able-ssl –able-so
kyk vir die gekose uitleg … Apache
kyk vir werkende mkdir -p … ja
kyk na grep wat lang lyne hanteer en -e … / usr / bin / grep
kyk vir egrep … / usr / bin / grep -E
kontroleer die boustelsel tipe … x86_64-onbekend-linux-gnu
kontroleer die gasheerstelsel tipe … x86_64-onbekend-linux-gnu
kontroleer die teikenstelsel tipe … x86_64-onbekende-linux-gnu
instel:
configure: Configureer Apache Portable Runtime-biblioteek…
instel:
kyk vir April … ja
stel CC op "gcc"
stel CPP op "gcc -E"
stel CFLAGS op " -g -O2-trap"
stel CPPFLAGS op " -DLINUX -D_REENTRANT -D_GNU_SOURCE"
stel LDFLAGS op " "
instel:
configure: Configureer Apache Portable Runtime Utility-biblioteek…
instel:
kyk vir AP-gebruik … nee
configure: error: APR-util nie gevind nie. Lees asseblief die dokumentasie.
[[Email protected] httpd-2.4.25] #

In die geval dat u ‘n “APR-util not found” -fout het, moet u ook installeer die volgende.

  • Laai die nuutste bron van APR af

wget https://www-eu.apache.org/dist/apr/apr-util-1.6.1.tar.gz .

  • Onttrek die afgelaaide gz-lêer

gunzip -c apr-util-1.6.1.tar.gz | teer xvf –

  • Gaan na die nuutgeskepte vouer “apr-util-1.6.1” en installeer dit met behulp van die volgende opdragte

./ configure – with-apr = / usr / local / apr / bin / apr-1-config
make
maak installeer

Probeer weer Apache installeer en kry nog ‘n fout.

pcre-config vir libpcre nie gevind nie

Dit is wat ek gekry het.

kyk of die C-samesteller werk … ja
kontroleer vir die C-samesteller se standaarduitvoerlêernaam … a.out
kyk na agtervoegsel van uitvoerbare programme…
kyk of ons kruis saamstel … nee
kyk vir agtervoegsel van objeklêers … o
kyk of ons die GNU C-samesteller gebruik … ja
kyk of gcc -g aanvaar … ja
kyk vir die gcc-opsie om ISO C89 te aanvaar … niks nodig nie
kyk hoe die C-voorverwerker uitgevoer word … gcc -E
kyk vir die gcc-opsie om ISO C99 te aanvaar … -std = gnu99
kyk vir pcre-konfigurasie … onwaar
configure: error: pcre-config vir libpcre nie gevind nie. PCRE is verpligtend en beskikbaar vanaf http://pcre.org/

PCRE staan ​​vir Perl Compatible Regular Expressions, en hierdie fout het ‘n maklike oplossing. U moet net pcre-devel-pakket installeer.

yum installeer pcre-devel

Nog nie verby nie, het nog ‘n volgende poging gekry wat verband hou met OpenSSL.

OpenSSL-weergawe is te oud

kyk of mod_slotmem_plain in staat sal stel … nee
kyk of mod_ssl … in staat gestel word om afhanklikhede te kontroleer
kyk na OpenSSL … soek na gebruikersgids OpenSSL-basisgids … ./configure: reël 25426: cd: / usr / bin / openssl: Nie ‘n gids nie
/root/httpd-2.4.25
en bygevoeg "-Ek / root / httpd-2.4.25 / sluit" na CPPFLAGS
stel MOD_CFLAGS op "-Ek / root / httpd-2.4.25 / sluit"
stel ab_CFLAGS op "-Ek / root / httpd-2.4.25 / sluit"
en bygevoeg "-L / root / httpd-2.4.25 / lib" na LDFLAGS
stel MOD_LDFLAGS op "-L / root / httpd-2.4.25 / lib"
kyk na OpenSSL-weergawe >= 0.9.8a … GEBEURT
opstel: WAARSKUWING: OpenSSL-weergawe is te oud
geen
kontroleer of mod_ssl … configure in staat sal stel: fout: mod_ssl is gevra, maar kan nie gebou word nie as gevolg van voorvereiste foute
[[Email protected] httpd-2.4.25] #

Die eerste ding wat u moet verseker dat u die nuutste weergawe van OpenSSL het, wat in my geval was, so ek moes die ontwikkel pakket, en dit was in orde.

yum installeer openssl-devel

xml / apr_xml.c: 35: 19: noodlottige fout: expat.h: Geen so ‘n lêer of gids nie

Ek het hierdie fout tydens die samestelling van April opgestel.

[[Email protected] apr-util-1.6.1] # maak
maak [1]: Entering directory `/opt/temp/apr-util-1.6.1 ‘
. 1.6.1 / sluit -I / opt / temp / apr-util-1.6.1 / insluit / privaat -I / usr / local / apr / sluit / apr-1 -o xml / apr_xml.lo -c xml / apr_xml. c && raak xml / apr_xml.lo
xml / apr_xml.c: 35: 19: noodlottige fout: expat.h: Geen so ‘n lêer of gids nie
#insluit
                   ^
samestelling beëindig.
maak [1]: *** [xml / apr_xml.lo] Fout 1

As u hierdie fout ondervind, kan dit opgelos word deur die expat-devel-pakket te installeer.

yum installeer expat-devel

configure: error: geen aanvaarbare C-samesteller word in $ PATH gevind nie

C-samesteller wat nie gevind word nie, is tipies vir enige sagteware-opbou, en u kan dit regstel deur die samesteller te installeer.

yum installeer gcc

nghttp2 weergawe is te oud

Dit is spesifiek wanneer u Apache met HTTP / 2 probeer installeer. U kry die volgende fout.

kontroleer of mod_http2 in staat gestel moet word … om afhanklikhede te kontroleer
kyk na OpenSSL … (cache) ja
stel MOD_LDFLAGS op " -lssl -lcrypto -lrt -lcrypt -lpthread"
stel MOD_CFLAGS op " "
stel MOD_CPPFLAGS op "-DH2_OPENSSL"
nagaan vir nghttp2 … soek vir nghttp2-basisgids wat deur die gebruiker voorsien is … geen
kyk vir pkg-config saam … kyk vir nghttp2-weergawe >= 1.2.1 … misluk
opstel: WAARSKUWING: nghttp2-weergawe is te oud
geen
kontroleer of mod_http2 in staat te stel … configure: error: mod_http2 is gevra, maar kan nie gebou word nie as gevolg van voorvereiste foute

En indien wel, kan u dit regmaak deur nghttp2 soos hieronder te installeer.

  • Laai die nuutste weergawe van nghttp2 af van hier

wget https://github.com/nghttp2/nghttp2/releases/download/v1.37.0/nghttp2-1.37.0.tar.gz

  • Onttrek die afgelaaide lêer

teer -xvf nghttp2-1.37.0.tar.gz

  • Dit sal ‘n nuwe lêergids skep, binnetoe gaan en die volgende uitvoer

./ instel
make
maak installeer

As u dit sonder fout gedoen het, moet u die Apache-bronopbou met HTTP2 weer uitvoer. Dit moet in orde wees.

Uiteindelik kon ek Apache suksesvol installeer. As u belangstel om te leer oor Apache HTTP-bedieneradministrasie, gaan kyk hierna aanlyn kursus.

Jeffrey Wilson Administrator
Sorry! The Author has not filled his profile.
follow me
    Like this post? Please share to your friends:
    Adblock
    detector
    map